Common Error Messages
Page 1 of 2

Author:  Kat [ 03-20-2005 06:44 PM ]
Post subject:  Common Error Messages

I've just uploaded a copy of the previous 'common error messages' thread to meh website. I tried a copy/paste into these 'ere forums but it's not seeing the HTML formatting even though it's 'on' :shrug: Anyway thanks to scourge34 for sending me the copy he had archived to his HDD so I could get this back up and running.

There are 34 errors mentioned and they're indexed now so you can click on a link at the top of the page and jump to whereever that entry is.

Common Error Messages

Author:  +JuggerNaut+ [ 03-20-2005 11:11 PM ]
Post subject: 

Scourge has his own teen angst backed up on his hdd

Author:  Kat [ 03-21-2005 09:19 AM ]
Post subject:  compile with -patchshadows on?

1 Q : Can someone explain me how to compile with -patchshadows on? Where and how do I execute / add this option? [BNA]

A : Assuming you don't want to go for a full out "let's go into DOS and compile the thing", then I suggest you either create a new bsp menu option, or modify the existing ones. This can be done using the project settings on the file menu. However, if i remember correctly, there is a line limit in the edit box, which truncates even the default ones, so you might have to open the project file up in notepad or something similar, and just add a new line there. If you study some of the existing ones, you are sure to understand the format. [djbob]

additional note : I had to add the -patchshadows option manually in Q3Radiant because of that line limit, but in GTK 1.1.1 using the built in editor seems to work just fine. [pjw]

Author:  Kat [ 03-21-2005 09:20 AM ]
Post subject:  WARNING: models/mapobjects/kmlamp_white.tga has empty alpha

2 Q : What do -

"WARNING: models/mapobjects/kmlamp_white.tga has empty alpha channel"


3 Q : "WARNING: brush plane with no normal"

mean?. I get a lot of each message in the console of radiant when loading my map. [vwperview]

A : First is harmless. Just means it doesn't have an alpha channel, which it doesn't NEED to have.The second is potentially more annoying. You have a brush with a f*cked up face which wont be shown. Vertex manipulation of the brush is likely to make it disappear and become a phantom brush, if it isn't already one. Brush cleanup will fix these. Alternatively, it could be a patch which you have manually rotated (NOT A GOOD IDEA), which is nasty, as you probably won't be able to see it in editor, but will show up in game. I (djbob) enhanced brush cleanup to sort these too. However, I never seem to have patched the changes.

To get rid of it, look through the map using notepad. If you see any patches which have co-ordinates that have a decimal point, round them manually. [djbob]

Author:  Kat [ 03-21-2005 09:21 AM ]
Post subject:  brush plane w/ no normal

4 Q : I've been using brush cleanup all along (the one that came w/ the latest version of GTK) and I have still had the "brush plane w/ no normal" problem. So I am guessing it's the rotated patch mesh that is causing it. What do you mean by manually rotating it? A lot of time I use the z-axis rotate 90 degrees button. Should I not do that?

And I looked in the .map file, I am assuming a patch looks something like this:

// brush 23 { patchDef2 { proto2/concrete02 ( 3 3 0 0 0 ) (( ( -1344 784 128 0 0 ) ( -1376 784 128 0 0.250000 ) ( -1408 784 128 0 0.500000 ) )( ( -1344 720 128 0.500000 0 ) ( -1376 720 128 0.500000 0.250000 ) ( -1408 720 128 0.500000 0.500000 ) )( ( -1344 720 64 1 0 ) ( -1376 720 64 1 0.250000 ) ( -1408 720 64 1 0.500000 ) )) } }

But which of those sets of numbers is the coordinates? [wviperw]

A : 90 degree rotation from the toolbar is fine. It's using r for manual rotate that can b*gger things up. The first three numbers inside the brackets in each case are the co-ords, so for this patch, everything is fine. [djbob]

Author:  Kat [ 03-21-2005 09:21 AM ]

5 Q : I've looked through the errors on the qeradiant page, but has anyone ever gotten this error while doing the -vis? :


I'm working on a, well... huge map and I'm noticing this problem more and more. Right now I'm only able to do the minimal BSP and test out the map, but I'd like to do lighting and everything else when I'm ready to present the finished project. Does anybody have any advice besides downsizing the map? [quakefraggin]

A : Yup... you've basically made your map to big! You've used up your allotted VIS data (it's around 2mb I think [2,040,000 as you see it reported in GTK bsp monitoring] someone will correct me on this though.) [Kat]

additional note (1) : Or use detail better so that the BSP is less complicated, and so requires less vis data. [djbob]

additional note (2) : Actually, it has nothing to do with the size of your map, but rather the structural complexity. Rather than cut down your map, you may want to consider rebuilding it taking vis into account.

Every structural brush face in a map has an associated plane. The higher the number of unique structural planes, the larger your vis data will be.

To clear up a common misconception, larger vis data does not mean vis is working harder or more effectively.

A gross oversimplification: The vis data is simply a collection of lists that answer "is this area visible from here?" Every location in a sealed, fully vis'ed map has such a list. The more unique "locations" in a map, the more memory the vis data will consume.

Those locations are BSP leaves. As the goal of the Quake 3 BSP compiler is to create a BSP with convex leaves (i.e., no interprojecting volumes), then the hairier the makeup of your structural brushes, the more leaves in the final BSP.

Certain individuals (myself included, on the rare occasion I'm mapping) subscribe to the notion of building for vis. That's simplifying it a bit, as there are other things to take into account, but the basic method is this:

Build the structural hull of the map entirely with caulk. Caulk is solid, opaque to vis, invisible to the eye, and unless changed in Radiant, structural.

Build what the player sees out of caulk detail brushes and patches, then texture the visible faces.

Share planes wherever possible. Terrain, or any other "meshy" mass of brushes, for instance, should share a single plane on the backside. Cutting down on the number of unique planes is a Good Thing.

If you're feeling up to it, read SPoG's Quake 3 BSP doc for a more in-depth explaination. [ydnar]

Author:  Kat [ 03-21-2005 09:22 AM ]
Post subject:  AAS shutdown

6 Q : 1. After compiling & pak'ing, I'll go to select the map ingame, but get booted to desktop with a console error:

"----- Server Shutdown -----
==== ShutdownGame ====
AAS shutdown.
Requested feature was omitted at compile time"

I'm not sure what request they mean, as i did a full vis & light extra.

2. Also, the q3map.exe always has to close during the -vis due to an error. Then it goes on with the -light. This happened with a previous map I made, and I had no problems with it from its pk3.

3. Whats the significance of the .prt file to the .bsp? Does this need to be done before vis/light? (Is it included?) As i've noticed, it's not there after doing the vis/light.

I'm using gtkRadiant 1.1 with xp. [psion]

A : 1. This problem occurs if you're using a jpg saved with progressive encoding as your levelshot. Use standard encoding instead. [Anwulf]

2. Found the nightly build (of gtk) is doing the trick. Wasn't aware it was a vis crash bug. [psion]

3. The .prt file contains the portal information which you'd use in conjunction with the portal viewer plugin. Unless you add a compile option to your projects file with the -saveprt switch, the .prt file is automatically deleted. [Anwulf]

Author:  Kat [ 03-21-2005 09:22 AM ]
Post subject:  stylenum == MAX_SWITCHED_LIGHTS

7 Q : I've placed some lights with targets (I don't know exactly if it causes the problem or not). Then when I complied I got this error.


What does this mean? [3tehakanyuksel]

A : This occurs with targeted lights. It's a Quake/Quake 2 vestige where targetnames were indexed for lightstyles. Since Quake 3 has no lightstyles (no flickering lights), you can't target light entities. [ydnar]

Author:  Kat [ 03-21-2005 09:23 AM ]
Post subject:  Line 178 is incomplete

8 Q : "Line 178 is incomplete"

A : I got that single error this morning when I tried to BSP and banged my head against the monitor for about an hour before I finally figured it out - so I thought I'd post something about it. I checked the .map file in a text editor, tried recreating brushes, etc, etc...

It was one of the shader files. I used, line 178: "surfaceparm" with no parameter. You'd never guess it from the error message. [[AF]haste]

Author:  Kat [ 03-21-2005 09:27 AM ]
Post subject:  UnmatchedToken "({)"

9 Q : I have a weird error. It started when I did something simple - retexturing two faces to caulk. Well, after I finished retexturing the second face, Radiant crashed (I have GTK 1.1.1, and I don't remember the error message. I get them all the time ).

Well, I thought, "Oh well, no big deal. All I did was chage two textures, I'll just reload and redo it." Then I go to reload, and I get an error message about an

UnmatchedToken "({)"

(or something) and Radiant crashes again. I'm started to get frustrated now, so I load it up a second time, same error, but about a different line. Now I'm pretty mad. I open up the map file in a text editor and find weird characters (éµÄ`æ¶, stuff like that), so, being that I had this stuff before, I deleted the brushes. [Pathogen]

A : An unmatched token message means that there's a "{" that lacks a matching "}" (or vice versa). The most frequent cause seems to be something going wrong at the very start of the .map file where the worldspawn info is. Open that .map file in a text editor, find an uncorrupted .map file, and copy over the missing info. You might also be able to use the map's .bak file to the same end provided there's nothing wrong with it. [Anwulf]

Author:  Kat [ 03-21-2005 09:28 AM ]


A : You have a brush that is too complex. [anon.]

You have too many brush sides (total), in your map. As simple as that. Possible solution, slice up brushes which have sides not visible to use fewer sides. [Kat]

Author:  Kat [ 03-21-2005 09:29 AM ]
Post subject: 

11 Q : What does this mean

************ ERROR ************
AllocWinding failed: MAX_POINTS_ON_WINDING exceeded


A : imagine the first square is you looking at the end of a brush. the face has 4 vertices.

[picture should be here]

now, in the second picture, we have another brush, the face which you can see is co-planar with the first face, such that the two vertices touch one edge of the face. the compiler will split that edge on the first face and add the two vertices shown in green to it, making it now have 6 vertices. with multiple repeated brushes, this can quickly build up to the max of 64. [djbob]

Author:  Kat [ 03-21-2005 09:30 AM ]
Post subject:  MAX_MAP_LIGHTING

12 Q : What does this mean

******Error MAX_MAP_LIGHTING****


A : The "LIGHTING" part of MAX_MAP_LIGHTING refers to the lightmaps created for the map.

Lightmap images are created by the third stage of the compile.. either by -light using the old light-tracing algorithm or -vlight using MrElusives Volume-casting light algorithm thingy.

Each Drawable Polygon surface has lightmap texture coordinates created for it by the first stage of the compile. The third stage creates the actual lightmap images for each surface, and all of these images are squeezed onto 'pages', with multiple lightmap images on each page. Each of these pages is 128*128 pixels in size, enough to cover 2048*2048 units of brush surface at the standard lightmap resolution (16*16 units per pixel). There is an upper limit on the number of lightmap pages that can be crammed into the BSP.. probably about 4mb. That works out to about 80 pages of lightmaps, which is quite a lot of surface area..

If all the sections of your maps compile fine individually, then it must be that the lightmap pages created for the combined map are greater than this limit.

There are two solutions to this problem:

1 : easy but lower quality, use 32*32units per LM pixel resolution.
q3map -samplesize 32 mapname
q3map -vis -saveprt mapname
q3map -vlight -samplesize 32 mapname

2 : more difficult but much better result, reduce the total surface area of the drawable polygons in the map. This will reduce the number/size of the lightmaps, reducing the number of lightmap pages created, reducing the total size of the lightmaps in the .bsp.
Drawable polygons are created for a surface even when that surface is hidden by a detail brush. Apply textures/common/caulk to these surfaces, or delete them entirely if they are patches.

Drawable polygons are also created for surfaces that are only partially hidden by structural brushes - and, providing that the drawable polygon is convex, parts of it may still be hidden behind structural brushes, taking up extra lightmap area. If there is a significant amount of the area on a surface hidden by a structural brush, split the surface up until only the visible part exists.

Author:  Kat [ 03-21-2005 09:31 AM ]
Post subject:  MAX_SUBMODELS exceeded

13 Q : I got this message while i was loading up my map

"MAX_SUBMODELS exceeded"

can u help me plz! [darkalan]

A : Believe it or not, the error is more related to entities, not models.Correct me if I'm wrong, but I think you're limited to 255 brush entities. If you exceed that amount, you'll get the 'MAX_SUBMODLES exceeded' error. Keep in mind that you can make ONE brush entity out of SEVERAL brushes, and it only counts as one. [Grand Nagus]

Author:  Kat [ 03-21-2005 10:15 AM ]
Post subject:  Chose a 0 valued axis

14 Q : What does this mean...

************ ERROR ************
Chose a 0 valued axis

A : this error occurs when you try to cap a cone. The problem is that the top of the cone get's a 0*0 cap. so... remove the top (read small) cap of that cone [Hr.O]

Author:  Kat [ 03-21-2005 10:16 AM ]
Post subject: 

15 Q : I get


when compiling my map. Though he tells me the entity and brush number, I can´t get rid of this msg, because deleting the brush seems not to affect this message, it just tells me another brush which "has" mixed contents.

I selected my whole level and made it detail, than I built a big Brush->CSG Make Hallow->func_group->make structural. That´s the way everbody does it, maybe my mapfile is messed up? ...and selecting the whole level again->make detail makes no differnce [libertyforrest]

A : I've seen this one before. Someone on here got it one time by making hint brushes into detail

"by making hint brushes into detail" exactly, i didn't filter the hint brushes when selecting and making it into detail, thx guys, now I have got a clean compile [libertyforrest]

Author:  Kat [ 03-21-2005 10:17 AM ]
Post subject:  blindingly bright (OverBright)

16 Q : Ok, EVERY level i make in Q3Radiant, after i compile it, is

blindingly bright (OverBright)

its down right annoying, and i cant change it, i dont remeber what option i changed, but i have re instaled radiant 3 times and even tho i put no lights in my level the world is bright as hell. (only my gun is dark, the way it should be) SOMEONE PLEASE HElP, i would like to get back to makeing my creations once again. [anon.]

A : There is a known bug that happens when your map is very small. Making it bigger will definitely help. You can also load your map in debug mode (console > type "/devmap mapname"), then when your map loads, type "/give all". Then switch to the BFG and magically the lighting pops in. [anon.]

Author:  Kat [ 03-21-2005 10:18 AM ]
Post subject:  (iKernel.exe)

17 Q : Maybe this one has come up before (even though I couldn't find it) but I get a strange error when I try to install GTK Radiant (1.2.1). The install program throws up a

The installshield engine (iKernel.exe) could not be installed. The cannot read from the specified drive

error. Anybody seen this before? [miez]

A : I've had this error in the past when trying to install from a 'corrupted' copy of the program - usually when trying to install from a CD backup of the app. I found that either redownloading the app or copying it (from the CD) onto the harddrive usually solved the problem.. seems especially so under Win98..!

Author:  Kat [ 03-21-2005 10:18 AM ]
Post subject:  long compile times

18 Q : I dont get an error exactly, vis gets to the 4... in the last count, then it stops, i check task manager and the process shows the "System idle process" at %99 and q3map at 0.

I thought maybe this was normal so i let q3map keep running, for 2 days, 40 hours to be exact, during that time the process stayed at 0 and the memory usage did not fluxuate althought task manager reported it as running.

-fast vis works, its only when i try full vis that it dosnt, the only errors i get are about 50 duplicat planes, (which the manual says is only a problem for .aas, yes i know ammazzing, someone who actually checks the manual first) anyone have any ideas?

A : Edit: Scratch that, got it worked out, let this be a lesson to other newbi's, USE DETAIL BRUSHES!!!

additional note : I'll try to sum it up in a few sentences if I can Mortal.... Select ALL the brushes in your map that DON'T touch the void and AREN'T part of walls, ceilings and floors (these brushes usually touch the void). When you have everything selected, hit Ctrl+M (make detail). Once a brush has been converted to detail, it won't be considered during the vis stage.

Right now, it seems that every brush in your map is considered during the vis stage...which has a max visdatasize of 2 MB. Convert everything I mentioned to detail and your map will compile the vis stage in a few seconds. [GONNAKILLYA!]

Author:  Kat [ 03-21-2005 10:19 AM ]

19 Q : MAX_POINTS_ON_WINDING error [anon.]

A : I've found a solution to the MAX_POINTS_ON_WINDING error, and it doesn't involve deleting any brushes. Use the -meta switch in your BSP compile, and the error doesn't pop up. Don't know why, don't know how, just know that it works.

Author:  Kat [ 03-21-2005 10:21 AM ]
Post subject:  duplicate planes

20 Q : The q3map2 compiler works on this error fine.
If you're using too much drag edges then you get this error. This is one of my worst nightmares.

****ERROR*** [insert error message here]

I hate this error so much. [reptile]

A : you'll probably find you've got some currupted brushes somewhere if that's the reason you think he error is happening. I take it you've used BobToolz to clean up the brushwork?? If you're still getting errors then you may need to go thru the map and check the brushwork you're been dragging about and manually fix any bad brushes.

Author:  Kat [ 03-21-2005 10:21 AM ]
Post subject:  LoadTGA: Only type 2 (RGB), 3 (gray), and 10 (RGB) TGA image

21 Q : I have the following compile error after loading the shaders :

********* ERROR ***********
LoadTGA: Only type 2 (RGB), 3 (gray), and 10 (RGB) TGA images supported.

How can i find out which tga-file doesn't fit ? [Strahlemann]

A : it's quite possibly not a *.tga at error here but more likely you've got a *.jpg in your working directory that's been saved with pregressive compression which Q3 doesn't like... resave the image without and you should be ok... [anon.]

Author:  Kat [ 03-21-2005 10:22 AM ]
Post subject:  Missing textures in game

22 Q : Missing textures in game

A : First of all, I'm not sure if this post belongs here or in the usual level editing forum. But on the other hand, this took me some days to figure out, and I couldn't find any documentation on it.

I added some shaders to the Q3Threewave assets pak, there are some bouncepads in there with red and blue glowing circles, but the ones I need for my map aren't in there. I copied the shader, placed it in my own and changed the source texture.

After adding the new shaders to some faces in my map and compiling it, it does NOT show up in game. I got the feared black and white tile. Must be something I did wrong. Checked the shader again, looks good. In GTK changed the faces again compiled again, you get the picture.

Because I am making this map ready for beta testing, still put the bugged bsp in a pk3 with the textures and shaders.

Guess what...

It works
For many of you this might be a perfectly explainable common error, but it cost me some precious mapping hours.

So, if you make shaders of your own and they DON'T work in game:
Check the shader again

Pack the bsp, textures and shaders in a pk3 file

Check if the shaders work in game now

Hope this saves some hours for another n00b mapper

Author:  Kat [ 03-21-2005 10:23 AM ]
Post subject:  Warning RE_Add Poly To Scene: Null Shader

23 Q : After doing a compile last night I tried to run the new map and half my textures were missing. In the console I was getting this message repeating.

Warning RE_Add Poly To Scene: Null Shader

Anyone know what I need to do to fix this. I didn't do a whole lot of changes between the last to compiles. Mostly added some clip textures to a few spots and made a few small new areas. [Pennywise]

A: posted on MapCenter - answered by PJ
Check this thread, where the same question was answered.

SOF2 may be using an older version of the compiling software. As a part of the Team Arena code, id redid the way that shaders are loaded. Broken shaders were treated as bad script code and broke the game and had to be fixed or removed if they were in the user's game folder.

You may have a broken shader in some script in a pak file. You may have written a bad shader yourself that the SOF2 compile was overlooking. Heck, it may even be a bad shader inside SOF2.

The method is to remove all extra content from your game folder and try to compile. If it works, then add in the files you most want back and try again. Repeat until the compile breaks. The most recently added file is your culprit.

Author:  Kat [ 03-21-2005 10:23 AM ]
Post subject:  Backwards Tree Volume

24 Q : ERROR: Backwards Tree Volume

A : I fixed the error only by setting all brushes touching the void to structural brushes. [HeavyBlade]

Just ran into this one on a small testmap, a few detailed detail brushes surrounded by a hollowed box of caulk, which was struct. and touching one edge of the detail brushes. Got rid of the error by making the caulkhull not touching the detail and getting rid of the overlapping parts of the caulkhull.

Author:  Kat [ 03-21-2005 10:24 AM ]
Post subject: 

25 Q : I was just remaking a map i'v done for another game, i put in a jump pad and a deathmatch start point, when i try to start it in quake i get

sp_worldspawn: the first entity isn't 'worldspawn'

. i want to know whats wrong. it worked fine before i put the jump pad on the map and the start point on the second level

[edit] i was using q3radiant instead of gtkradiant, the error might not happen now [measter]

A : The 'worldspawn' entry at the top of your *.map file is missing. Open up an older version of the map in a text editor and copy the 1st line (or copy what you see in that one that's not present in the latest map file), paste it into place at the top of the newer file and save.

If you can open the map in Radiant select an brush object and right click, select 'move into worldspawn' and then save the map. Hopefully that should have created the 'worldspawn' key that's needed for the map to work.

Make sure to make a backup before you do this so you can go back if it totally borks up as has been known to happen.

25b Q : works fine now that i got gtkradiant, though i did have to sart the map again [measter]

before you re-do all that work try these 1st... look for the autosave backup files, you'll have 2, one's actually called 'autosave.map' and the other 'your_last_maps_name.bak.

The autosave you load into Radiant like any other map. The *.bak file needs to be 'loaded' into Radiant (file > load) or you can change the file extension to *.map and it'll load up.

Make sure you version save your maps from now on if you're not doing this already, each time you do significant changes save a new file... [kat]

Author:  Kat [ 03-21-2005 10:25 AM ]
Post subject:  too fast a compile time

26 Q : hey, i ahve got it 2 gtkradiant to compile the maps sometimes, But sometimes it just closes when i try to compile it as anything other that "BSP". i starts to do something but then closes. i have this problem when compiling anymap. i have even tried uninstalling gtkradiant and then installing it again. has anybody got any ideas on what is goin on? [sk8rocksam]

A : I would suggest you take a look at the GTKradiant console ('o' key IIRC)... sometimes the compile times are so short one can hardly follow the infos in the dosbox windows, the console will track the compile, so you can read up on the possible warnings/errors there.

Author:  Kat [ 03-21-2005 10:25 AM ]
Post subject:  multiple crossing points for patch - can't clip

27 Q : Compiling an RtCW SP map with q3m2.2.38 I get this error cropping up

multiple crossing points for patch - can't clip

It happens during the initial stage of a BSP compile (once it's run thru the shaders and 'longest curve' entries). It doesn't bork out the process (and q3map2 happily continues to do the rest of the process) so I just wondered what it ment.. I'm guessing it's someting to do with a wierd twist in a patch mesh somewhere (due to miss-aligned control points?) that means clipping the mesh isn't completed?? [kat]

A : IIRC that's due to a patch cutting the surface of a fog brush more than once, because the compiler can only split the patch once. [dayve]

Author:  Kat [ 03-21-2005 10:26 AM ]
Post subject:  RE_LoadWorldMap: maps/testctf1.bsp not found

28 Q : I got...

RE_LoadWorldMap: maps/testctf1.bsp not found

(testctf1 is the map name) anyone got a clue on this one? I followed a Q3 Radiant manual and did exactly as it said (even in the sample map) and it did not load in Quake 3. [MEtAL]

A : you tried 'sv_pure 0'? Did you put the map file into a pk3? If not try that as I seem to remember someone saying pk3 files have preference over folders/files in baseq3 (the game will look at pk3 files 1st) Also make sure you have an info_player_start [kat]

Author:  Kat [ 03-21-2005 10:26 AM ]
Post subject:  Shader_max_vertexes hit in FillCloudy Sky Side

29 Q : Shader_max_vertexes hit in FillCloudy Sky Side
A : Basically, the error says what it means, your sky shader is asking the engine to render much more in the way of cloud domes than it allows for. Usually caused by either sky shaders with two or more cloud stages and a really massive area visible in game, or sky shaders with three or more stages.

In general, be wary of using more than two cloud stages in your sky shaders. Using sky portals may now be a good alternative if you feel a standard sky isn't interesting enough. [Shallow[BAP]]

Author:  Kat [ 03-21-2005 10:28 AM ]
Post subject:  choose 0 valued axis

30 Q : I got...

choose 0 valued axis

during initial stage of BSP, couldnt find what it meant with search. Didnt have anything to do with the last number of brushes i'd placed, i think. Quite irritating as i can't continue, can anyone help me out? [fischu]

A : I'm not sure how valid a solution this is (I'm seriously guess-ti-mating) but that might be related to you using an axis of rotation on an entity set with '0' rather than 360 (which is the default '0'). Check your entities for a key/value pairing of angle/0.

A quick way to check entities is to open the map entity info browser (keyboard 'L') and go down the listing selecting each entry and reading what it says.. once you found the bad entity (assuming it is a '0' angle error) click the 'select' button and then 'close' the browser.

30b Q : Checked all entities, no angle/0 pairs. I found a light with an angle, but that diddnt fix my error. Deleted and remade everything i did since last succesful compile, still the same darn error. q3map2 disconnects after the error.

Sorry for posting this here, never came across such an error. I hope someone has.

A : what version of q3map2 are you using??

30c Q : Using latest? 2.5.11 something like that, d/led this week, doubt tho wether version of q3map2 really matters. It's probably something stupid, but i've got no idea where to start looking. your suggestion seemed like the most logical explenation.

isnt there some sort of listing, i mean whoever programmed q3map should know what it means, right?

A : the answer was in this thread funnily enough...

"************ ERROR ************
Chose a 0 valued axis A.

this error occurs when you try to cap a cone. The problem is that the top of the cone get's a 0*0 cap. so... remove the top (read small) cap of that cone [Hr.O]"

30d Q : The thing is, i havn't capped a cone since the last succesful compile. I do recall thickening one by 2 units, would this have the same effect? Also I've already deleted everything I'd built since the last compile. Or would I have to do open it up in notepad and look for a patch with a 0*0? angle, I do hope there's an easier solution as I don't think I would know what to look for, patches I can recognize but the bunch of numbers under that I can not. thx for the help tho.

A : do a quick test map, just a box with a cylinder mesh in it. Cap the cylinder and then try a compile (don't forget a player spawn as well), if you a clean compile then you know that 'cylinders' are generally ok and there is a problem with a mesh in the previous map file.

What the error actually means is in capping the cone (or cylinder) you've created a mesh section that is so small that it no longer has a valid size 'X' x 'Y' units. If you're still getting the error now then it means there *is* a mesh somewhere causing the problem. Thickening in of itself won't necessairly cause the problem so the best thing to try is to hide the patch related brushwork (Ctrl+P) and select/copy/paste everything else to a fresh new map file. Don't add any meshwork/cylinders to this file and just do a compile to check it's ok. Once you've done that, if it compiles ok, you can then either rebuild the patch work or copy/paste that stuff from the old file one mesh section at a time compiling a new file each time (so you can backtrack when you find the error) it's a bit of a long winded way to find the problem patchmesh but if you can't remember where it might have started to happen you have to be quite methodical in tracking it down.

You could probably track it down in notepad but the entry might not actually be '0*0' on the patch mesh. Open the map file any ways and have a look for a patchmesh func_group and see if you can find anything out of place.. make back up versions of the file as you work as you could totall bork up the file by deleting entries like that.

30e Q : yeah, did it. Lazy as i am i tried to think of a quicker way, simply placed brushes where i had thickend the cones, and clicked on the select inside button. And as you said 2 tiny white lines/dots appeared. Hitting the backspace button really made me smile. Compiling sweetly now.

Author:  Kat [ 03-21-2005 10:28 AM ]
Post subject:  MAX_MAP_PLANES

31 Q : MAX_MAP_PLANES[kat]

A : messing about with some ASE model produced this error during BSPC (for RtCW) as a result of them being q3map_clipmodel. Removed that and manually clipping the models solved the issue. The clipped ASE models were creating an excessive number of 'planes' which broke thru the limit. [kat]

Author:  Kat [ 03-21-2005 10:29 AM ]
Post subject:  MAX_LEAF_FACES

32 Q : Are there some unwritten rules concerning the making of portals? I have had to simplify the portal I made for my WIP considerably just to get it to compile. It appears that a portal's geometry cannot go beyond a certain level of complexity, nor can it be too large (i.e. the size of the world or larger). I got the...


... error in the BSP stage when I attempted to construct some buildings from brushwork in my portal. I've now just made a few simple buildings, ASE'd them and cloned/rotated them, and there's no problems.
Has anyone had this error before? What's the different between a BSP leaf's face and its portal? [seremtam]

A : This error occurs when you have too many drawsurfaces in a single BSP leaf. The max is 0x2000 (8192). You must have some exceedingly complex set of surfaces or are not using q3map_nonplanar or meta to merge stuff, or using _blocksize with a value too high or simply not splitting them map up enough.

I don't recall the last time I saw anyone get that error. [ydnar]

additional note : or your skybox area is too complex. Try to keep it reasonable, because the 8192 leaf/surface max means you're limited to 8192 surfaces in your skybox. Usually less, since sky leaves tend to have other surfaces already in them.

Author:  Kat [ 03-21-2005 10:29 AM ]
Post subject: 

33 Q : MAX_MAPFILE_PLANES (max mapfile planes) [kat]

A : Associated with AAS files for BOTs or AI. Usually caused by using large numbers of models (with q3map_clipModel in a shader) or large numbers of patch meshes in a map.

For models - removing q3map_clipModel from shader and manually clipping with weaponsclip (or some other clip brush) seems to fix this.

For patchmesh - depending on the number of models in a map, converting patch mesh work to ase models sometimes helps (leave clipModel out of shader) to remove the error.

But for AAS problems ydnar has noted that "BSPC needs to be updated with larger allowable values for planes, brush sides, etc." This effects any quake3 engined games using BOTs or AI. [kat]

Author:  Kat [ 03-21-2005 10:30 AM ]
Post subject:  ERROR: Line {Insert line number here} is incomplete

34 Q : ERROR: Line {Insert line number here} is incomplete [fjoggs]

A : In the previous case, this was fixed by easily copy the entire map in text form (open up the .map file in a text editor and copy everything), and then paste it into a new .txt file, then rename it to .map and open it. Run a brush clean up, and you should be good to go. [fjoggs]

Page 1 of 2 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group