Common Error Messages
Page 2 of 2

Author:  roughrider [ 03-21-2005 03:45 PM ]
Post subject: 

Thanks for the recovery of this very useful thread kat :icon14: .
This place is looking more and more like home each day.

Author:  Kat [ 03-21-2005 06:30 PM ]
Post subject: 

Don't forget to make it sticky so it's always visible. I only added the answered questions to the list btw, there were about 6 or so left unanswered which I'll sort out and post at some point.

Author:  Shallow [ 03-22-2005 02:23 AM ]
Post subject: 

SV_SetBrushModel: NULL

Caused by a brush entity such as a func_door or func_plat with no solid brushes, or a func_rotating with no origin brush. If you've added anything like that recently, check it, and add a solid brush if necessary. If you can't find anything, look though the entity list and see if you can find an entity that should have brushes but has somehow lost them. Note that a adding something like a clip brush is enough to make the entity qualify as having solid brushes, if you are using a model as a func_ entity.

Author:  roughrider [ 03-22-2005 03:47 PM ]
Post subject: 

Kat wrote:
Don't forget to make it sticky so it's always visible. I only added the answered questions to the list btw, there were about 6 or so left unanswered which I'll sort out and post at some point.

Sure np :)

Author:  AEon [ 04-23-2005 02:17 PM ]
Post subject: 

Just niced up the capitalization of the topic and was wondering if there is any interest in me "niceing" up this thread somewhat like in the links section or nicer :)... IMO it would be more handy to have all those message merged into the first 2-3 posts, to make a browser search for the messages quicker. I'd place the posts into one of kat's post, so that Kat should be able to edit it as well.

If there is interest, this will not happen soon, but at some point in the future :)

Author:  Kat [ 04-24-2005 06:46 AM ]
Post subject: 

I kinda posted it the way it is so that each error had it's own 'section' and subheading (that title on the upper right of each post) I just think it makes it easier to read 'as is' rather than having all the posts in one giant bit of text.

If you want to spruce it up, I guess just make sure each error is clearly defined from it's neighbours - which was a problem with the last version.

Author:  Fjoggs [ 04-24-2005 06:52 AM ]
Post subject: 

Shallow wrote:
SV_SetBrushModel: NULL

Caused by a brush entity such as a func_door or func_plat with no solid brushes, or a func_rotating with no origin brush. If you've added anything like that recently, check it, and add a solid brush if necessary. If you can't find anything, look though the entity list and see if you can find an entity that should have brushes but has somehow lost them. Note that a adding something like a clip brush is enough to make the entity qualify as having solid brushes, if you are using a model as a func_ entity.

This problem is easily solved using brush_cleanup from bobtoolz. :)

Author:  obsidian [ 08-18-2005 08:21 PM ]
Post subject: 

WARNING: reused image skybox/texture/path.tga with mixed glWrapClampMode parm

Appears in the game console whenever a map is compiled with -skyfix. You can safely ignore this error.

Author:  AEon [ 05-26-2006 12:52 PM ]
Post subject: 

Q3A Common Error Messages FAQ

    v3.5 - 35 Q&As, for Quake 3 - 5/26/2006
    Original edit by Kat for Q3W.com LEM, layout change and re-edit by AEon

    (* Marks changes since v3.5)

      The following lists various compile Error Messages, Warnings, misc other mapping related problems, and explains how to fix them. These are mostly Q3A related, but should be applicable to the other games using the Q3 engine.

      Also see Common Error Messages @ quake3bits.com by Kat.

      Note: I have tried to make the Questions in the Q&As as concise as possible for quicker easier reading. (AEon)

    • Error: AllocWinding failed: MAX_POINTS_ON_WINDING exceeded
    • Error: Backwards Tree Volume
    • Error: Chose a 0 valued axis
    • Error: Duplicate Planes
    • Error: Line 178 is incomplete
    • Error: Line <line number> is Incomplete
    • Error: LoadTGA: Only type 2 (RGB), 3 (gray), and 10 (RGB) TGA image
    • Error: MAX_LEAF_FACES
    • Error: MAX_MAP_PLANES
    • Error: MAX_SUBMODELS Exceeded
    • Error: MAX_VISIBILITY_EXCEEDED during -vis?
    • Error: Multiple Crossing Points for Patch - Can't Clip
    • Error: iKernel.exe
    • Error: stylenum == MAX_SWITCHED_LIGHTS

    • Warning: RE_Add Poly To Scene: Null Shader
    • Warning: Reused image <skybox image> with mixed glWrapClampMode parm
    • Warning: models/mapobjects/kmlamp_white.tga has Empty Alpha

    Misc Problems
    • AAS Shutdown?
    • Brush Plane with no Normal
    • Choose 0 Valued Axis
    • Compile Time too short to follow Console Output
    • Full Bright Map (OverBright)
    • How to compile with -patchshadows on?
    • How to reduce long Compile Times?
    • RE_LoadWorldMap: maps/testctf1.bsp not found
    • SV_SetBrushModel: NULL
    • Shader_max_vertexes hit in FillCloudy Sky Side
    • Shaders not working and Missing Textures In-game?
    • UnmatchedToken "({)"
    • sp_worldspawn: 1st Entity is not 'worldspawn'

    FAQ Related
    • Credits
    • History

How to compile with -patchshadows on?
      Where and how do I execute / add this option? [BNA]

      Assuming you do not want to go for a full out "let us go into DOS and compile the thing", then I suggest you either create a new BSP menu option, or modify the existing ones. This can be done using the Project Settings on the File menu. However, if I remember correctly, there is a line limit in the edit box, which truncates even the default ones, so you might have to open the project file up in notepad or something similar, and just add a new line there. If you study some of the existing ones, you are sure to understand the format. [djbob]

      Note: I had to add the -patchshadows option manually in Q3Radiant because of that line limit, but in GTKradiant v1.1.1 using the built in editor seems to work just fine. [pjw]

Warning: models/mapobjects/kmlamp_white.tga has Empty Alpha
      What do

      WARNING: models/mapobjects/kmlamp_white.tga has empty alpha channel


      WARNING: brush plane with no normal

      mean? I get a lot of these messages in the Radiant's console when loading my map. [vwperview]

      The first one is harmless. Just means it does not have an alpha channel, which it does not need to have.

      The second is potentially more annoying. You have a brush with a messed up face which will not be shown. Vertex manipulation of the brush is likely to make it disappear and become a phantom brush, if it is not already one. Brush Cleanup (Plugins menu, bobToolz) will fix these. Alternatively, it could be a patch which you have manually rotated (not a good idea), which is nasty, as you probably will not be able to see it in editor, but will show up in game. I (djbob) enhanced Brush Cleanup to sort these too. However, I never seem to have patched the changes.

      To get rid of it, look through the .map using notepad. If you see any patches which have coordinates that have a decimal point, round them manually. [djbob]

Brush Plane with no Normal
      I have been using Brush Cleanup all along (the one that came with the latest version of GTKradiant) and I have still had the "brush plane with no normal" problem. So I am guessing it is the rotated patch mesh that is causing it. What do you mean by manually rotating it? A lot of time I use the Z-axis rotate 90 degrees button. Should I not do that?

      And I looked in the .map file, I am assuming a patch looks something like this:

      // AEon: Added indents, map source does *not* use indents!
      // brush 23
            ( 3 3 0 0 0 )
            ( ( -1344 784 128 0 0 ) ( -1376 784 128 0 0.250 ) ( -1408 784 128 0 0.500 ) )
            ( ( -1344 720 128 0.500 0 ) ( -1376 720 128 0.500 0.250 ) ( -1408 720 128 0.500 0.500 ) )
            ( ( -1344 720 64 1 0 ) ( -1376 720 64 1 0.250 ) ( -1408 720 64 1 0.500 ) )

      But which of those sets of numbers is the coordinates? [wviperw]

      90 degree rotation from the toolbar is fine. It is using R-key for manual rotate that can mess things up. The first three numbers inside the brackets in each case are the coordinates, so for this patch, everything is fine. [djbob]

      Has anyone ever gotten this error while doing the -vis compile:


      I am working on a, well... huge map and I am noticing this problem more and more. Right now I am only able to do the minimal BSP and test out the map, but I would like to do lighting and everything else when I am ready to present the finished project. Does anybody have any advice besides downsizing the map? [quakefraggin]

      Yup... you have basically made your map too big! You have used up your allotted VIS data (it is around 2 MB I think [2,040,000 as you see it reported in GTKradiant Bsp monitoring] someone will correct me on this though.) [Kat]

      Note: Or use Detail better so that the BSP is less complicated, and so requires less vis data. [djbob]

      Note: Actually, it has nothing to do with the size of your map, but rather the structural complexity. Rather than cut down your map, you may want to consider rebuilding it taking vis into account.

      Every structural brush face in a map has an associated plane. The higher the number of unique structural planes, the larger your vis data will be.

      To clear up a common misconception, larger vis data does not mean vis is working harder or more effectively.

      A gross oversimplification: The vis data is simply a collection of lists that answer "is this area visible from here?" Every location in a sealed, fully vis'ed map has such a list. The more unique "locations" in a map, the more memory the vis data will consume.

      Those locations are BSP leaves. As the goal of the Quake 3 BSP compiler is to create a BSP with convex leaves (i.e., no interprojecting volumes), then the hairier the makeup of your structural brushes, the more leaves in the final BSP.

      Certain individuals (myself included, on the rare occasion I am mapping) subscribe to the notion of building for vis. That is simplifying it a bit, as there are other things to take into account, but the basic method is this:

      Build the Structural Hull of the map entirely with caulk. Caulk is solid, opaque to vis, invisible to the eye, and unless changed in Radiant, structural.

      Build what the player sees out of caulk detail brushes and patches, then texture the visible faces.

      Share planes wherever possible. Terrain, or any other "meshy" mass of brushes, for instance, should share a single plane on the backside. Cutting down on the number of unique planes is a Good Thing.

      If you are feeling up to it, read SPoG's Quake 3 BSP doc for a more in-depth explanation. [ydnar]

AAS Shutdown?
      1. After compiling and pak'ing, I will go to select the map in-game, but get booted to desktop with a console error:

      ----- Server Shutdown -----
      ==== ShutdownGame ====
      AAS shutdown.
      Requested feature was omitted at compile time

      I am not sure what request they mean, as I did a full vis and light extra?

      2. Also, the q3map.exe always has to close during the -vis due to an error. Then it goes on with the -light. This happened with a previous map I made, and I had no problems with it from its .pk3.

      3. What is the significance of the .prt file to the .bsp? Does this need to be done before vis/light? (Is it included?) As I have noticed, it is not there after doing the vis/light.

      I am using GTKradiant v1.1 under XP. [psion]

      1. This problem occurs if you are using a .jpg saved with progressive encoding as your levelshot. Use standard encoding instead. [Anwulf]

      2. Found the nightly build (of GTKradiant) is doing the trick. Was not aware it was a vis crash bug. [psion]

      3. The .prt file contains the portal information which you would use in conjunction with the Portal Viewer plugin. Unless you add a compile option to your projects file with the -saveprt switch, the .prt file is automatically deleted. [Anwulf]

Error: stylenum == MAX_SWITCHED_LIGHTS
      I have placed some lights with targets (I do not know exactly if it causes the problem or not). Then when I complied I got this error:

      stylenum == MAX_SWITCHED_LIGHTS

      What does this mean? [3tehakanyuksel]

      This occurs with targeted lights. It is a Quake/Quake 2 vestige where targetnames were indexed for lightstyles. Since Quake 3 has no lightstyles (no flickering lights), you cannot target light entities. [ydnar]

Error: Line 178 is incomplete
      Line 178 is incomplete

      I got that single error when I tried to BSP. I checked the .map file in a text editor, tried recreating brushes, etc, etc...

      Turns out it was one of the Shader files. In line 178 I used surfaceparm without a parameter. You would never guess it from the error message. [[AF]haste]

UnmatchedToken "({)"
      I have a weird error. It started when I did something simple - retexturing two faces to caulk. Well, after I finished retexturing the second face, Radiant crashed (I have GTKradiant v1.1.1, and I do not remember the error message. I get them all the time).

      Well, I thought, "Oh well, no big deal. All I did was change two textures, I will just reload and redo it." Then I go to reload, and I get an error message about an

      UnmatchedToken "({)"

      (or something) and Radiant crashes again. I load it up a second time, same error, but about a different line. I open up the .map file in a text editor and find weird characters (e.g. éµÄ`æ¶), so, being that I had this stuff before, I deleted the brushes. [Pathogen]

      An unmatched token message means that there is a "{" that lacks a matching "}" (or vice versa). The most frequent cause seems to be something going wrong at the very start of the .map file where the worldspawn info is. Open that .map file in a text editor, find an uncorrupted .map file, and copy over the missing info. You might also be able to use the map's .bak file to the same end provided there is nothing wrong with it. [Anwulf]


      You have a brush that is too complex. [anon.]

      You have too many brush sides (total), in your map. As simple as that. Possible solution, slice up brushes which have sides not visible to use fewer sides. [Kat]

Error: AllocWinding failed: MAX_POINTS_ON_WINDING exceeded
      What does this mean [mehoo]:

      **** ERROR ****
      AllocWinding failed: MAX_POINTS_ON_WINDING exceeded

      Imagine the first square is you looking at the end of a brush. The face has 4 vertices.

      [picture missing]

      Now, in the second picture, we have another brush, the face which you can see is co-planar with the first face, such that the two vertices touch one edge of the face. The compiler will split that edge on the first face and add the two vertices shown in green to it, making it now have 6 vertices. With multiple repeated brushes, this can quickly build up to the maximum of 64. [djbob]

      What does this mean [anon.]:

      ****Error MAX_MAP_LIGHTING****

      The "LIGHTING" part of MAX_MAP_LIGHTING refers to the lightmaps created for the map.

      Lightmap images are created by the third stage of the compile... either by -light using the old light-tracing algorithm or -vlight using MrElusive's Volume-casting light algorithm thingy.

      Each Drawable Polygon surface has lightmap texture coordinates created for it by the first stage of the compile. The third stage creates the actual lightmap images for each surface, and all of these images are squeezed onto "pages", with multiple lightmap images on each page. Each of these pages is 128*128 pixels in size, enough to cover 2048*2048 units of brush surface at the standard lightmap resolution (16*16 units per pixel). There is an upper limit on the number of lightmap pages that can be crammed into the BSP... probably about 4 MB. That works out to about 80 pages of lightmaps, which is quite a lot of surface area.

      If all the sections of your maps compile fine individually, then it must be that the lightmap pages created for the combined map are greater than this limit.

      There are two solutions to this problem:
      • Easy but lower quality, use 32*32units per LM pixel resolution.
        q3map -samplesize 32 <mapname>
        q3map -vis -saveprt <mapname>
        q3map -vlight -samplesize 32 <mapname>

      • More difficult but much better result, reduce the total surface area of the drawable polygons in the map. This will reduce the number/size of the lightmaps, reducing the number of lightmap pages created, reducing the total size of the lightmaps in the .bsp.

        Drawable polygons are created for a surface even when that surface is hidden by a detail brush. Apply textures/common/caulk to these surfaces, or delete them entirely if they are patches.

        Drawable polygons are also created for surfaces that are only partially hidden by structural brushes - and, providing that the drawable polygon is convex, parts of it may still be hidden behind structural brushes, taking up extra lightmap area. If there is a significant amount of the area on a surface hidden by a structural brush, split the surface up until only the visible part exists.

      Also read Technical by SPoG.

Error: MAX_SUBMODELS Exceeded
      I got this message while I was loading up my map [darkalan]:

      MAX_SUBMODELS exceeded

      Believe it or not, the error is more related to entities, not models. Correct me if I am wrong, but I think you are limited to 255 brush entities. If you exceed that amount, you will get the MAX_SUBMODLES exceeded error. Keep in mind that you can make one brush entity out of several brushes, and it only counts as one. [Grand Nagus]

Error: Chose a 0 valued axis
      What does this mean:

      **** ERROR ****
      Chose a 0 valued axis

      This error occurs when you try to Cap a cone. The problem is that the top of the cone gets a 0*0 cap. So... remove the top (read small) cap of that cone. [Hr.O]

      I get


      when compiling my map. Though it tells me the entity and brush number, I cannot get rid of this message, because deleting the brush does not seem to affect this message, it just mentions another brush which "has" mixed contents.

      I selected my whole level and made it Detail, than I built a big Brush -> CSG Make Hallow -> func_group -> Make Structural. That is the way everybody does it, maybe my map file is messed up? And selecting the whole level again -> Make Detail makes no difference. [libertyforrest]

      Someone here got it once by turning hint brushes into detail.

      That is exactly what happened. I did not filter the hint brushes when selecting and turning them into detail by accident. Now I have a clean compile. [libertyforrest]

Full Bright Map (OverBright)
      Every level I build in Q3Radiant - after compiling it - is

      blindingly bright (OverBright)

      and I cannot seem to fix this. I do not remember what option I changed, but I have reinstalled Radiant 3 times and even though I put no lights in my level the world is full bright. Only my gun is dark - the way it should be. [anon.]

      There is a known bug that happens when your map is very small. Making it bigger will definitely help. You can also load your map in debug mode (on console type /devmap mapname), then when your map loads, type /give all. Then switch to the BFG and magically the lighting pops in. [anon.]

Error: iKernel.exe
      I get a strange error when I try to install GTKradiant v1.2.1. The install program throws up a

      The Installshield engine (iKernel.exe) could not be installed. It cannot read from the specified drive

      error. Anyone seen this before? [miez]

      I have had this error in the past when trying to install from a "corrupted" copy of the program - usually when trying to install from a CD backup of the app. I found that either re-downloading the app or copying it (from the CD) onto the harddrive usually solved the problem. Seems especially so under Win98!

How to reduce long Compile Times?
      I do not get an error exactly, vis gets to the 4... in the last count, then it stops, I checked the Task Manager and the process shows the "System idle process" at %99 and q3map at 0%.

      I thought maybe this was normal so I let q3map keep running, for 2 days, 40 hours to be exact, during that time the process stayed at 0 and the memory usage did not fluctuate although the Task Manager reported it as running.

      -fast vis works, it is only when I try full vis that it does not. The only errors I get are about 50 duplicate planes, (which the manual says is only a problem for .aas, yes I know amazing, someone who actually checks the manual first). Anyone have any ideas? [Mortal]

      Scratch that, got it worked out, let this be a lesson to other beginners: Use detail brushes!

      Note: I will try to sum it up in a few sentences if I can Mortal.... Select all the brushes in your map that do not touch the void and are not part of walls, ceilings and floors (these brushes usually touch the void). When you have everything selected, hit Ctrl + M (Make Detail). Once a brush has been converted to detail, it will not be considered during the vis compile stage.

      Right now, it seems that every brush in your map is considered during the vis stage... which has a maximum visdatasize of 2 MB. Convert everything I mentioned to detail and your map will compile the vis stage in a few seconds. [GONNAKILLYA!]

      MAX_POINTS_ON_WINDING error [anon.]

      I have found a solution to the MAX_POINTS_ON_WINDING error, and it does not involve deleting any brushes. Use the -meta switch in your BSP compile, and the error does not pop up. I do not know why, do not know how, just know that it works.

Error: Duplicate Planes
      The q3map2 compiler works on this error fine. If you are using too much Drag Edges then you get this error though [reptile]:

      ***ERROR*** <insert error message here>

      You will probably find you have got some corrupted brushes somewhere if that is the reason you think the error is happening. I take it you have used the bobToolz to clean up the brushwork (Plugins menu, bobToolz, Brush Cleanup)? If you are still getting errors then you may need to go through the map and check the brushwork you have been dragging around and manually fix any bad brushes.

Error: LoadTGA: Only type 2 (RGB), 3 (gray), and 10 (RGB) TGA image
      I have the following compile error after loading the shaders:

      **** ERROR ****
      LoadTGA: Only type 2 (RGB), 3 (gray), and 10 (RGB) TGA images supported.

      How can I find out which .tga file does not fit? [Strahlemann]

      It is quite possibly not a .tga file at error here but more likely you have got a .jpg in your working directory that is been saved with Progressive Compression which Q3 does not like. Resave the image without and you should be OK. [anon.]

Shaders not working and Missing Textures In-game?
      What to do when textures are missing in the game?

      I added some shaders to the Q3Threewave assets pak, there are some jumppads in there with red and blue glowing circles, but the ones I need for my map are not in there. I copied the shader, placed it in my own shader file and changed the source texture.

      After adding the new shaders to some faces in my map and compiling it, they do not show up in-game. Instead I see the default black and white tile texture. Checked the shader again and tried again. Did not help alas.

      Because I am making this map ready for beta testing, I put the buggy .bsp into a .pk3 with the textures and shaders. Now it works!

      So, if you make shaders of your own and they do not work in game:
      • Check the shader again.
      • Pack the bsp, textures and shaders into a .pk3 file.
      • Check if the shaders work in game now.

      Comment: I have the feeling this is a priority problem, e.g. the same shader name in scripts\ superseding the one mentioned above, and that once in a .pk3 file the "right" shader is actually read first. [AEon]

Warning: RE_Add Poly To Scene: Null Shader
      After doing a compile I tried to run the new map and half my textures were missing. In the console I was getting this message repeatedly:

      Warning RE_Add Poly To Scene: Null Shader

      Anyone know what I need to do to fix this? I did not do many changes since my last compile. Mostly added some clip textures to a few spots and made a few small new areas. [Pennywise]

      SOF2 may be using an older version of the compiling software. As a part of the Team Arena code, id redid the way that shaders are loaded. Broken shaders were treated as bad script code and broke the game and had to be fixed or removed if they were in the user's game folder.

      You may have a broken shader in some script in a pak file. You may have written a bad shader yourself that the SOF2 compile was overlooking. Heck, it may even be a bad shader inside SOF2.

      The method is to remove all extra content from your game folder and try to compile. If it works, then add in the files you most want back and try again. Repeat until the compile breaks. The most recently added file is your culprit. [Posted on MapCenter - answered by PJ]

Error: Backwards Tree Volume
      ERROR: Backwards Tree Volume

      I fixed the error turning all brushes touching the void to structural brushes. [HeavyBlade]

      Just ran into this one on a small test map, a few detailed detail brushes surrounded by a hollowed box of caulk, which was structural. And touching one edge of the detail brushes. Got rid of the error by making the caulk hull not touching the detail and getting rid of the overlapping parts of the caulk hull.

sp_worldspawn: 1st Entity is not 'worldspawn'
      I was just remaking a map I have done for another game, I put in a jumppad and a deathmatch start point, when I try to start it in Quake3 I get:

      sp_worldspawn: the first entity is not 'worldspawn'

      What is going on? It worked fine up until added the jumppad and the spawn point to the map.

      [Edit] I was using Q3radiant instead of GTKradiant, the error might not happen now. [measter]

      The 'worldspawn' entry at the top of your .map file is missing. Open up an older version of the map in a text editor and copy the 1st line (or copy what you see in that one that is not present in the latest .map file), paste it into place at the top of the newer file and save.

      If you can open the map in Radiant select a brush object and right-click, select Move into Worldspawn and then save the map. Hopefully that should have created the worldspawn key that is needed for the map to work.

      Make sure to make a backup before you do this so you can go back if it totally borks up as has been known to happen.

        Works fine now that I got GTKradiant, though I did have to start the map again. [measter]

      Before you re-do all that work try these 1st: Look for the autosave backup files, you will have 2, one is actually called autosave.map and the other your_last_maps_name.bak.

      The autosave you load into Radiant like any other map. The .bak file needs to be 'loaded' into Radiant (File menu, Load) or you can change the file extension to .map and it will load up.

      Make sure you save your map from time to time. If you are not doing this already, each time you do significant changes save to a new file! [Kat]

Compile Time too short to follow Console Output
      Compiling my maps from GTKradiant works at times. But sometimes it just closes when I try to compile it with anything other than "BSP". It starts to do something but then closes. I have this problem when compiling any map. I have even tried deinstalling GTKradiant and then installing it again. What is going on? [sk8rocksam]

      I would suggest you take a look at the GTKradiant console (O-key IIRC)... sometimes the compile times are so short one can hardly follow the infos in the dosbox windows, the console will track the compile, so you can read up on the possible warnings/errors there.

Error: Multiple Crossing Points for Patch - Can't Clip
      Compiling a RtCW SP map with q3map2 v2.2.38 I get this error:

      Multiple crossing points for patch - Can't clip

      It happens during the initial stage of a BSP compile (once it is run through the shaders and 'longest curve' entries). It does not bork out the process (and q3map2 happily continues to do the rest of the process) so I just wondered what it meant. I am guessing it has something to do with a weird twist in a patch mesh somewhere (due to miss-aligned control points?) that means clipping the mesh is not completed? [Kat]

      IIRC that is due to a patch cutting the surface of a fog brush more than once, because the compiler can only split the patch once. [dayve]

RE_LoadWorldMap: maps/testctf1.bsp not found
      testctf1 is my test map, that yields:

      RE_LoadWorldMap: maps/testctf1.bsp not found

      Anyone got a clue on this one? I followed a Q3Radiant manual and did exactly as it said (even in the sample map) and it did not load in Quake 3. [MEtAL]

    • You tried sv_pure 0?
    • Did you put the .map file into a .pk3?
      If not, try that as I seem to remember someone saying .pk3 files have preference over folders/files in baseq3\ (the game will look at .pk3 files 1st).
    • Also make sure you have an info_player_start entity in your map. [Kat]

Shader_max_vertexes hit in FillCloudy Sky Side
      Shader_max_vertexes hit in FillCloudy Sky Side

      Basically, the error says what it means, your sky shader is asking the engine to render much more in the way of cloud domes than it allows for. Usually caused by either sky shaders with two or more cloud stages and a really massive area visible in game, or sky shaders with three or more stages.

      In general, be wary of using more than two cloud stages in your sky shaders. Using sky portals may now be a good alternative if you feel a standard sky is not interesting enough. [Shallow[BAP]]

Choose 0 Valued Axis
      I got

      choose 0 valued axis

      during initial stage of BSP. Did not have anything to do with the last number of brushes I placed, I think though. [fischu]

      It might be related to your using an axis of rotation on an entity set with 0 rather than 360 (which is the default 0). Check your entities for a key/value pairing of angle/0.

      A quick way to check entities is to open the map Entity Info browser (L-key) and go down the listing selecting each entry and reading what it says. Once you found the bad entity (assuming it is a 0 angle error) click the Select button and then Close the browser.

      Checked all entities, no angle/0 pairs. I found a light with an angle, but that did not fix my error. Deleted and remade everything I did since last successful compile, still the same error. q3map2 disconnects after the error.

      What version of q3map2 are you using?

      Using latest? v2.5.11, doubt though whether version of q3map2 really matters. It is probably something stupid, but I have got no idea where to start looking.

      The answer was in this thread funnily enough:

      ************ ERROR ************
      Chose a 0 valued axis A.

      This error occurs when you try to Cap a Cone. The problem is that the top of the cone gets a 0*0 cap. So... remove the top (read small) cap of that cone [Hr.O]

      The thing is, I have not capped a cone since the last successful compile. I do recall thickening one by 2 units. Would this have the same effect? Also I have already deleted everything I had built since the last compile. Or would I have to do open it up in notepad and look for a patch with a 0*0? angle, I do hope there is an easier solution as I do not think I would know what to look for, patches I can recognize but the bunch of numbers under that I can not.

      Do a quick test map, just a box with a cylinder mesh in it. Cap the cylinder and then try a compile (do not forget a player spawn as well), if you a clean compile then you know that "cylinders" are generally OK and there is a problem with a mesh in the previous .map file.

      What the error actually means is in capping the cone (or cylinder) you have created a mesh section that is so small that it no longer has a valid size 'X' x 'Y' units. If you are still getting the error now then it means there *is* a mesh somewhere causing the problem. Thickening in of itself will not necessarily cause the problem so the best thing to try is to hide the patch related brushwork (Ctrl + P) and select/copy/paste everything else to a fresh new .map file. Do not add any meshwork/cylinders to this file and just do a compile to check it is OK. Once you have done that, if it compiles OK, you can then either rebuild the patch work or copy/paste that stuff from the old file one mesh section at a time compiling a new file each time (so you can backtrack when you find the error) it is a bit of a long winded way to find the problem patch mesh but if you cannot remember where it might have started to happen you have to be quite methodical in tracking it down.

      You could probably track it down in notepad but the entry might not actually be 0*0 on the patch mesh. Open the .map file anyway and look for a patch mesh func_group and see if you can find anything out of place. Make backup versions of the file as you work as you could totally mess up the file by deleting entries like that.

      yeah, did it. Lazy as I am I tried to think of a quicker way, simply placed brushes where I had thickened the cones, and clicked on the select inside button. And as you said 2 tiny white lines/dots appeared. Hitting the backspace button really made me smile. Compiling sweetly now.

      MAX_MAP_PLANES [Kat]

      Messing around with some ASE model produced this error during BSPC (for RtCW) as a result of them being q3map_clipmodel. Removed that and manually clipping the models solved the issue. The clipped ASE models were creating an excessive number of 'planes' which broke through the limit. [Kat]

      Are there some unwritten rules concerning the building of Portals? I have had to simplify the portal I made for my WIP considerably just to get it to compile. It appears that a portal's geometry cannot go beyond a certain level of complexity, nor can it be too large (i.e. the size of the world or larger). I got the


      error in the BSP stage when I attempted to construct some buildings from brushwork in my portal. I have now just made a few simple buildings, ASE'd them and cloned/rotated them, and there are ano problems. Has anyone had this error before? What is the difference between a BSP leaf's face and its portal? [seremtam]

      This error occurs when you have too many drawsurfaces in a single BSP leaf. The maximum is 0x2000 (8192). You must have some exceedingly complex set of surfaces or are not using q3map_nonplanar or meta to merge stuff, or using _blocksize with a value too high or simply not splitting them map up enough.

      I do not recall the last time I saw anyone get that error. [ydnar]

      Note: Or your skybox area is too complex. Try to keep it reasonable, because the 8192 leaf/surface max means you are limited to 8192 surfaces in your skybox. Usually less, since sky leaves tend to have other surfaces already in them.

      MAX_MAPFILE_PLANES (Max Mapfile Planes) [Kat]

      Associated with AAS files for Bots or AI. Usually caused by using large numbers of models (with q3map_clipModel in a shader) or large numbers of patch meshes in a map.

      For Models - removing q3map_clipModel from shader and manually clipping with weaponsclip (or some other clip brush) seems to fix this.

      For Patch Meshes - depending on the number of models in a map, converting patch mesh work to ASE models sometimes helps (leave clipModel out of shader) to remove the error.

      But for AAS problems, ydnar has noted that "BSPC needs to be updated with larger allowable values for planes, brush sides, etc." This affects any Quake3 engine games using Bots or AI. [Kat]

Error: Line <line number> is Incomplete
      ERROR: Line <Insert line number here> is incomplete

      In the previous case, this was fixed easily by copying the entire map in text form (open up the .map file in a text editor and copy everything), and then paste it into a new .txt file, then rename it to .map and open it. Run a Brush Cleanup (Plugins menu, bobToolz), and you should be good to go. [Fjoggs]

SV_SetBrushModel: NULL
      SV_SetBrushModel: NULL

      Caused by a brush entity such as a func_door or func_plat with no solid brushes, or a func_rotating with no origin brush. If you have added anything like that recently, check it, and add a solid brush if necessary. If you cannot find anything, look though the entity list and see if you can find an entity that should have brushes but has somehow lost them. Note that adding something like a clip brush is enough to make the entity qualify as having solid brushes, if you are using a model as a func_ entity. [Shallow]

      This problem is easily solved using Brush Cleanup from Plugins menu, bobToolz . [Fjoggs]

Warning: Reused image <skybox image> with mixed glWrapClampMode parm
      WARNING: reused image skybox/texture/path.tga with mixed glWrapClampMode parm

      Appears in the game console whenever a map is compiled with -skyfix. You can safely ignore this error. [Obsidian]

FAQ Related

      Thanx go to the folks here at Level Editing and Modeling @ quake3world.com (LEM) and Kat for putting together the original list.

      Where known those asking and those answering questions are mentioned in angled brackets.

      Alas while reading the Q&As I *had* to fix some spelling and typos and unclear passages, or irrelevant explicatives.[AEon]

    • v3.5 35 Q&As total, 0 new Q&As, 0 updates, 0 split, numerous changes, since v1.0 (5/26/2006)
    • v1.0 Converting the original posts edited by Kat into a new format, using highlighting, corrected spelling, sorted Q&As into categories, added index. (5/26/2006)

Author:  AEon [ 05-26-2006 12:56 PM ]
Post subject: 

Must have been out of my mind and bored enough to undertake the above re-design on the Error Messages. I had planned to do it in between mapping pauses, but turned out to be a 8 hour or so job... sigh.

Fixed tons of spelling errors and typos, made posts more logical, etc and added an Index.

It is my hope that we can merge this thread into one of the other ones, like the Link Resources Thread, so save one sticky.

Any corrections, improvement suggestions welcome.

Hope it is actually an improvement.

Author:  monaster [ 05-26-2008 05:41 AM ]
Post subject:  Re: Common Error Messages


I'm not too sure if that error message isn't already treated in Kats #33, if it is, shame on me because I can't make any sense out of the provided solution. Sorry...
Oh yeah, the error strangely occured on a map which has nothing special in it except one HUGE rounded hill made out of a cone whose first and second half were flipped in order to get a nice hill to build a fortress on it. And it has definitely to do with that hill (or the map hull around it but that's very unlikely for the hull is nothing more than a hollowed brush without any shaders) since the error message popped up during compiling that single change and never ever before.

Author:  obsidian [ 05-26-2008 05:58 AM ]
Post subject:  Re: Common Error Messages

monaster wrote:

ydnar wrote:
Your map has too many/complex patches. Either remove some of them, bake them into an ASE, or use a nonsolid shader.


Author:  obsidian [ 12-09-2008 09:41 AM ]
Post subject:  Re: Common Error Messages

Jusser wrote:
entity 0 brush 9 fog has multiple visible sides

Fog brushes can have at maximum, one visible face. It can either be a universal fog volume encompassing the entire bounds of the map, or it can have a single visible face from which you can enter into the fog volume (like the "fog of death" pits). If two or more sides are exposed to 'open air' then you will get this error message.

Author:  Bliccer [ 12-23-2009 01:50 PM ]
Post subject:  Re: Common Error Messages

Here you can get a full list of all those error messages in a neat pdf I made:

Q3A Common Error Messages

Author:  Bliccer [ 04-14-2010 02:19 PM ]
Post subject:  Re: Common Error Messages

I will do a new post since this is a new file...
I've just edited my pdf file. You can get the new version here:


- added 4 new messages:
Error: target_speaker without a noise key at (xxx xxx xx),
Warning: could not find path/filename.wav – using default
Warning: music file in path/filename.wav is not 22k stereo
No data chunk in filename.wav
- changed the alphabetical order of the errors (ikernel)
- deleted some breaks
- fixed level-designer.de link

I hope it's still useful somehow/sometimes.

Author:  Bliccer [ 08-11-2010 01:30 PM ]
Post subject:  Re: Common Error Messages

Here you get a new version of the Error list:


- extended the Bots just standing around in the map section

The online version is updated, too, ofc:


Furthermore I formated the whole page, so the validator shows a green page.
Also the  should be gone. Maybe you haven't even recognized.

Author:  Bliccer [ 09-11-2010 12:36 PM ]
Post subject:  Re: Common Error Messages

So here is a new version with 2 new error messages and some new words in another topic:

Q3A Common Error Messages v1.5.pdf

- edited one link
- added some lines in the Shaders not working and Missing Textures In-game? section
- added two new messages to the list:
Error: MAX_SHADER_INFO Exceeded (thanks to morbus)
CM_Inlinemodel: Bad Number

Again: If you get any new errors not stated here, write it into this thread or send me a pm. Also if you find smth with the formatting.

Author:  obsidian [ 04-03-2013 01:18 PM ]
Post subject:  Re: Common Error Messages

MAX_MAP_ENTITIES - Generally speaking, you have too many entities in your map, but there are all sorts of specifics on what is and isn't counted to that limit and what the game needs reserved for other stuff. There is a full discussion here:


Author:  Gustavo6046 [ 10-29-2015 12:30 PM ]
Post subject:  Re: Common Error Messages

Once a time I tried to compile gusq3dm6 AAS but bspc stated it was leaked. The leak was not visible in GtkRadiant.
The fix was simple: check for brushes that weren't clipping (I could pass through) and remake them.
Please add this to your Q&A.

Page 2 of 2 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group