GTK Radiant 1.40
Page 1 of 2

Author:  richfromlondon [ 08-18-2015 02:16 PM ]
Post subject:  GTK Radiant 1.40


I am trying to select a brush, I'd like to just make a copy of it and paste it nearby. I've tried Ctrl and left mouse button, but that doesn't work. :confused: I also tried the entity window, that has a list of various parts of the map I'm trying to edit.

I did read the guide, it explained how to select a brush. All I can seem to do with the map window is create a new brush.

Author:  Eraser [ 08-18-2015 09:04 PM ]
Post subject:  Re: GTK Radiant 1.40

Shift+left mouse button to select
Spacebar to duplicate your selection

Author:  richfromlondon [ 08-19-2015 04:40 AM ]
Post subject:  Re: GTK Radiant 1.40

Now that actually works.

So there isn't any ctrl use. Is there any easier way of selecting multiple brushes in one area. I'm having a bit of difficulty with selecting so many pieces in one area to move.

Author:  CZghost [ 08-19-2015 05:03 AM ]
Post subject:  Re: GTK Radiant 1.40

Just Shift+drag your LMB over brushes you want to select. They should be right next to each other in the view, no visible gap that might allow unwanted selecting of further brushes. These however can be deslected as prescribed above. Shit+LMB click works as a toggle select/deselect. The same works for drag...

Author:  CZghost [ 08-19-2015 05:06 AM ]
Post subject:  Re: GTK Radiant 1.40

Anyway, GtkRadiant 1.4 is outdated version, the last stable release is 1.6.4, which is basicaly the same except for some additions: fixes errors with some types of video cards, has an option to disable Windows Aero temporarily and supports more games via game packs. It includes also developer version of Quake Live (WolfCam QL)...

Author:  richfromlondon [ 08-19-2015 05:25 AM ]
Post subject:  Re: GTK Radiant 1.40

My computer is twelve years old. I'm editing a map for the twenty hundred released game, Elite force.

Slight error in your first post there, :p

I'll try this whole section over multiple brushes. My PC did a restart as I was just moving a bunch of bruses. Werid, I guess 1.5GB of RAM wasn't enough to keep the Fire Fox browser open and GTK.

Author:  richfromlondon [ 08-19-2015 06:19 AM ]
Post subject:  Re: GTK Radiant 1.40

In this image, I cannot select this piece. The arch, it won't budge, I keep trying to select it.

Piecewontmove.JPG [ 174.34 KB | Viewed 402 times ]

Author:  CZghost [ 08-19-2015 08:14 AM ]
Post subject:  Re: GTK Radiant 1.40

Well, then it's absolutely another chapter when you use also outdated OS :olo:

Your map seems to use mainly patches (curves). That's pretty ridiculous as patches need to be sealed off the void by structural brushes. It is considered detail, just as you set detail brushes, they also need to be sealed off. Compiler first takes only everything structural (and worldspawn), then it moves to detail brushes and patches (and models). If you are using too much patches, it will be just a way too slow to render even in editor. Especialy with older setup. I did not study how selecting patches really works, but they are usualy grouped with their caps, which you may use Alt+Shift+LMB click - and fragging won't help you in this case. You can check out if the patch is in a group (func_group) or alone in worldspawn by selecting it (single piece) and pressing N on your keyboard. If it says "classname" "func_group", it is grouped with caps (or another patches you might group yourself), otherwise there should be "classname" "worldspawn", which means it is standing alone. It seems you are using one-coloured textures - I can't see edges, I can't help you, though...

Author:  richfromlondon [ 08-19-2015 08:25 AM ]
Post subject:  Re: GTK Radiant 1.40

I'm a little confused, patches? Is that what they are called the brushes shaped that way?

Author:  Eraser [ 08-19-2015 08:41 AM ]
Post subject:  Re: GTK Radiant 1.40

Patches aren't ordinary brushes. In more common terminology, they're used to create curved surfaces. Their shape is controlled by dragging vertex points rather than the edges of an ordinary brush. Creating a map entirely out of patches isn't unprecedented, but only in a highly experimental fashion.

Since patches don't block visibility for the renderer, geometry behind a patch is drawn*, which is a hit on performance. Since a BSP map should be sealed off from the outside world using vis-blocking brushes (also called structural brushes). If your entire map consists of patches, you'll have to put a big structural box around it. This would technically be correct but causes your entire map to always be drawn, which kills performance.

Usually the idea is to make rough geometry (walls, ceilings/skies and floors) out of structural brushes and add detail using patches and (you guessed it) detail brushes.

*this is a grossly oversimplified statement, but serves to illustrate the point I'm trying to make.

Author:  richfromlondon [ 08-19-2015 10:14 AM ]
Post subject:  Re: GTK Radiant 1.40

Hmm, well the map was obviously never made by myself, it was created in 2002. I last used GTK in 2005, this version and it's okay.

I'm just trying to edit a few pieces here and there, and certainly delete some of it.

I was able to found one section I needed, Um, I've deleted the other lift and boarded the map up, so all I can do is compile it and run it, hopefully with less pieces the better. It has a space coloured texture around the whole map. So long as that is sealed it should run?

Author:  richfromlondon [ 08-19-2015 02:07 PM ]
Post subject:  Re: GTK Radiant 1.40

Now that I've tried to move a piece of the elevator now one piece is somehow connected to another. So when I move one, both move.

It appears moving a lift from where it is to a new location is proving far too challenging, and rather quite annoying. I may have to accept leaving one where it is, and just edit what ever else I can.

According to a blueprint I've seen, the lift doesn't belong there, a couple of walls to the left is where it is suppose to be.

Author:  CZghost [ 08-20-2015 11:46 PM ]
Post subject:  Re: GTK Radiant 1.40

By "lift" you mean func_plat? It needs to be built in raised position, otherwise it will be very buggy. I have a simple trick to do so: Build it lower, group it with func_plat, which gives that group function of elevator/lift, move it to the raised position I need, add height key with value of height I moved the lift (there can help temporary brush that could be from bottom side of raised lift to bottom side of lowered lift and settings to show metrics of brush selection - this will be the height key) and texture it there :)

Author:  Eraser [ 08-21-2015 03:04 AM ]
Post subject:  Re: GTK Radiant 1.40

func_plat is really odd in Q3 anyway. The sound files for it aren't even included. I've seen maps where a triggered func_door is used instead of a func_plat.

Author:  Eraser [ 08-21-2015 03:06 AM ]
Post subject:  Re: GTK Radiant 1.40

Oh as for selected large groups of brushes, you can also create a big brush, select it and in the menu go to "selection" > "select" > "select inside" and it'll select all of the brushes that are inside the selected brush and remove the initially selected brush.

Author:  richfromlondon [ 08-22-2015 04:37 AM ]
Post subject:  Re: GTK Radiant 1.40

The whole problem with the map I've tried to edit is, I've looked in Func_group, func_wall, static, and none of it has an actual piece to the arches. So what I did was exclude them out.

When I tried to compile the map it wouldn't. My other alternative could be to keep everything intact, but just board up the map, to block off the parts I don't want the player to go to.

Author:  CZghost [ 08-22-2015 07:04 AM ]
Post subject:  Re: GTK Radiant 1.40

Well, you downloaded that map out from somewhere and need to retouch it? You could ask V1979 to help, he has pretty rich experiences with retouching maps (see his q3dm CTF remakes). If everything is slower when opened up GTK Radiant with this map, try to increase RAM memory. I think 2 GB should be enough, but Win XP SP3 should see up to 3 GB RAM... I am using Windows 7 Home 32bit with maximum of 3 GB RAM on setup from original Windows XP installation (there I had 2 GB RAM with Win XP, and Radiant was just working fine)...

All I can tell you is try to improve your machine setup (add RAM, change your CPU to something better, buy new video card, etc.)... Also, you are using OS that is no longer officialy supported by Microsoft, neighter any other software company. I'm afraid to tell you to upgrade your OS to something newer - Windows 7 is good choice, though it's now pretty old. I did not test Windows 8 (and Win 8.1) deeper, I can't suggest you upgrade to Windows 10 - it is fresh release and it possibly will get more updates. Also some people say it is collecting data of users: key strokes, their faces, voice, possibly sending data to NSA, in side of other american companies. But these are only speculations, so I can't swear... They might then build up not only their visual and voice profile, but also mental profile from how they are acting on computer. Users with Win 7 and newer OS can download Win 10 upgrade for free via special download manager, but since there are speculation about spy software hard-coded in the OS itself, I'm giving up the upgrade yet before any confirmation (or denial instead) appears... But staying with OS that is updated, however not so frequently as before which means a hidden bomb timer before updates will be stopped definitely and that OS will be vulnerable against hack attacks in full weakness... Upgrade your OS at least to Windows 7 or you can give a try to Linux or Mac OS-X - GtkRadiant as well as Quake 3 and possibly Elite Force are working also under these OS's...

Author:  richfromlondon [ 08-22-2015 11:40 AM ]
Post subject:  Re: GTK Radiant 1.40

I appreciate your explanations.

Unfortunately, I don't have that option.

This system was using 512MB in 2004, up until September 2008. I upgraded to a total of 1.5GB of RAM, and no anti virus usage. I removed that last year.

I use Firefox as you'd of notice. I receive a few updates from MS, so its fine.

And I used GTK 1.40 on this same system back then, I was fourteen years old, fifteen years old.

The map was completed by the original map maker in early 2004, there was no use for it and never released up until 2006.

Compiling time isn't a problem, the map isn't that massive. If I can succeed with Icarus scripting, I'd need to create a surface elsewhere and another skybox for a mission.

But leaving that aside.

I've tried looking through the whole entity list, I didn't find the objects. The alternative is just to board it up, and just leave the lift where it is.

It should really be two places away going down or left depending on where positioned.

Author:  richfromlondon [ 08-23-2015 06:37 AM ]
Post subject:  Re: GTK Radiant 1.40

I was able to delete the arches, how ever now all the textures are all messed up. I press T to load the textures and select a brush and add a texture, how ever they don't display. So how can I fix this?

I tried creating a new map with adding a shuttlepod from the existing map I've been trying to edit. It doesn't work.

I've typed five emails to the original map maker, no reply. The odds are really stack against me, Icarus scripting for a couple of scenarios, a bit of map editing, then the texture mess up.

I've only succeeded with editing an existing script, and that is it. I'd be lucky enough to even get a couple of free .wav sound snippets for some of the NPC characters from the actual actress and actor of two NPC's as an example.

My only other option to remove an NPC without using GTK is to simply delete the model and textures or just the model from the map via the file location.

Author:  CZghost [ 08-23-2015 07:58 AM ]
Post subject:  Re: GTK Radiant 1.40

What video card do you use? ATI and Intel video cards have known issue with polygons disappearing, which has been fixed in Radiant 1.6 releases as optional settings... Radiant 1.4 does not have this, though...

Or do you see flatshaded surfaces or wireframe everywhere? Then try to change texture quality to at least bilinear mipmap :)

Author:  richfromlondon [ 08-23-2015 01:41 PM ]
Post subject:  Re: GTK Radiant 1.40

This version of GTK is from December 2003. So the actual map was made with a previous version, but I also would of imagined this version too.

I have a few screen here just displaying what I'm trying to do with Icarus scripting, if anyone can give a pointer or two, just how do I get that NPC to move to the green coloured brush, or navpoint, I believe all that is needed is what is there, as well as the actual script which I have made.

//Generated by BehavEd

rem ( "Sato Walks test" );
set ( /*@SET_TYPES*/ "SET_PARM1", "nav1" );
set ( "BSTATE", "BS_WALK" );
set ( "NAVGOAL1", "nav1" );

I'll need to sort out the texture problem there, the walls aren't suppose to look like that, the textures need to be stretched further so it is just one strip of wall plating.

sato.JPG [ 77.43 KB | Viewed 378 times ]
sato 2.JPG
sato 2.JPG [ 206.4 KB | Viewed 355 times ]
sato 1.JPG
sato 1.JPG [ 208.92 KB | Viewed 376 times ]

Author:  CZghost [ 08-24-2015 12:21 AM ]
Post subject:  Re: GTK Radiant 1.40

Textures are flatshaded. Check out texture quality settings. It should be on Bilinear Mipmap at least (Trilinear is the best). If it is at bilinear mipmap or trilinear, but still flat shaded, then try to check texture stretching. I'm not sure if Radiant can shrink texture down to 0, but if it is, or it is really near 0, you may need to increase texture stretch to your needs...

Author:  richfromlondon [ 08-24-2015 04:58 AM ]
Post subject:  Re: GTK Radiant 1.40

Thank you for that information.

I have managed to texture a few brushes, how ever, does that mean I must individually do so?

One of the problems I have with the bottom light is, the actual light is one image, then the top part is a different texture. How am I going to texture different pieces if they one brush?

Author:  Eraser [ 08-24-2015 05:12 AM ]
Post subject:  Re: GTK Radiant 1.40

ctrl+shift+Left mouse button in the 3D view to select individual faces of a brush.

As for texturing stuff, yeah, that's usually a brush-by-brush (or even face-by-face) thing. You can search/replace one texture into another texture throughout your map though.

Author:  richfromlondon [ 08-24-2015 05:52 AM ]
Post subject:  Re: GTK Radiant 1.40

Search for a texture? That sort of implies that I may not remember where they go? I have a reference image to assist me with this, it isn't that challenging, the Icarus scripting will be quite a challenge for a few variations of the map.

Or is that some kind of shortcut to texturing?

Author:  Eraser [ 08-24-2015 06:13 AM ]
Post subject:  Re: GTK Radiant 1.40

No what I mean is if you have used texture "X" in several places in your map and you want to replace every instance of texture "X" with texture "Y", then you can use the search/replace feature to do this automatically. I think it also offers the option to only search/replace within your current selection.

Author:  richfromlondon [ 08-24-2015 01:13 PM ]
Post subject:  Re: GTK Radiant 1.40

Hmm, Well I've done okay with the texturing I think.

Another question I have, just what does or how do the BSP compile options setup the map?

What is recommended?

Thank you.

bsplist.JPG [ 25.8 KB | Viewed 14126 times ]

Author:  CZghost [ 08-25-2015 12:35 AM ]
Post subject:  Re: GTK Radiant 1.40

That varies. If you want just a quick compile to test your map, choose testing compiles (marked as test)... If you want to compile final version, final marked compiles are good choices, but best you do with custom compile - best take Q3Map2Toolz which is graphical interface for compiler settings. It has simply a lots of features Q3Map2 does offer, though it is quite older version, so it does not support all these features, but it supports most of them. If you want to build very own compile settings, you can learn from q3map2 guidelines on Wikibooks and build your own batch file (*.bat)...

Author:  richfromlondon [ 08-25-2015 07:42 AM ]
Post subject:  Re: GTK Radiant 1.40

The original map when loaded was much darker in lighting, as the example image shows it is much brighter, even if I did swith the light settings in one part of the deck, which I have yet to even try, it probably wouldn't change much, as they are exactly the same as the original map.

Author:  CZghost [ 08-25-2015 10:50 AM ]
Post subject:  Re: GTK Radiant 1.40

He might add light by using levels in Photoshop. Also, if you set /r_mapoverbrightbits 3 - you will get much more enlighted map :)

Author:  richfromlondon [ 08-26-2015 05:55 AM ]
Post subject:  Re: GTK Radiant 1.40

Oh, my interest is in getting it darker as it originally was.

Hmm, I've stumbled on another problem, a model doesn't appear to be loading, it does display in the map on a container. When I did move it, and compiled it was no longer visible in the map.

I also tried to add a weapon, again with this model no weapon in the map. I have tried to open the Elite force Pak files on this computer and on a Windows 8.1 and they don't open. Only two of four pak files open. What is strange is I could days ago open Pak 0 and 3. They will contain script examples of NPC's walking as well as textures and the model weapons files.

I thought that by may be extracting those then the weapon would load in the map.

I'd of thought the game would load weapons in any map, even if there was no model or texture files in the Map's Pk3 file. And I can't even open the Mission pack PK3 file for a weapon that I'd definately need to go with this themed map.

Author:  richfromlondon [ 08-27-2015 04:52 AM ]
Post subject:  Re: GTK Radiant 1.40

Out of the choices for compilation, the first eight don't seem to work for my map, unlike the few after the compilation goes through a couple of command windows explaining the brushes, lights, and total entities in the map.

And they always state the failure in error in loading padd.m3d file. It does appear in the game, I've deleted it as it was on a cargo container and no use to the player, one of the characters is holding one, so obviously it does load for the character.

Author:  richfromlondon [ 08-30-2015 01:53 PM ]
Post subject:  Re: GTK Radiant 1.40

While transfering the Turbo lift from the original map, I compiled the map, and now it won't load into it, this is the error.


Author:  CZghost [ 08-31-2015 12:13 AM ]
Post subject:  Re: GTK Radiant 1.40

I had this error couple of times when loading my testing map. It simply means you have somewhere ghost brushes (brushes with zero width) - they won't appear in the Radiant and you can't select them by mouse. But when compiled, it will cause this error. You have to delete them. I do not know if there is some automatic tool that searches for these ghost brushes and deletes it automatically, but you can use google to search for that tool. But I can't tell you how to remove them manually because I'm not sure how to do it actualy...

Author:  Martinus [ 08-31-2015 04:03 AM ]
Post subject:  Re: GTK Radiant 1.40

Maybe "Brush Cleanup" ? Maybe.

Page 1 of 2 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group