Quake3World.com Forums
     Quake III Arena/Quake Live Discussion
        Vista 32bit gamma fix (nvidia)...


Post new topicReply to topic
Login | Profile | | FAQ | Search | IRC





Previous topic | Next topic 
Topic Starter Topic: Vista 32bit gamma fix (nvidia)...

Gibblet
Gibblet
Joined: 12 Aug 2006
Posts: 18
PostPosted: 05-10-2008 11:49 AM           Profile Send private message  E-mail  Edit post Reply with quote


I noticed when I installed Vista the other day with the 169.35 drivers that Quake 3 has problem changing the gamma. I remember the same problem when I installed XP sometime back in 2001. Thankfully, id solved this in later patches. But again I see alot of people having these types of problems. I looked at different forums and to my knowledge there wasn't really a decent fix for this. Some said setting r_ignorehwgamma to 1 made it better, but not not much imo.

I also remember when I had this issue with xp that if you set the game to run in compatiblility mode to win98, it looked better. So I tried this in Vista and sure enough the gamma issue was fixed. But another problem occured, the game wouldn't run past 60fps. I'm running with a LCD display. I thought I somehow set the r_finish to 1, or r_swapinterval to 1, but I hadn't.

What struck me was that I couldn't remember having a gamma problem with Vista before, prior to nov/dec 2007. I guess it's a driver issue.

So I looked through the Nvidia control panel, and tried out different settings. The solution is simple.

In Manage 3D Settings / Vertical Sync, change it to Force Off.
Now the game runs smooth again.

I'm guessing this applies to most openGL games including COD.




Top
                 
Quake3World.com | Forum Index | Quake III Arena/Quake Live Discussion


Post new topic Reply to topic


cron
Quake3World.com
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group