Quake3World.com Forums
     Announcements
        Login Issues update - Delete your cookies


Post new topicReply to topic
Login | Profile | | FAQ | Search | IRC




Previous topic | Next topic 
Topic Starter Topic: Login Issues update - Delete your cookies

Messatsu Ko Jy-ouu
Messatsu Ko Jy-ouu
Joined: 24 Nov 2000
Posts: 43162
PostPosted: 05-30-2017 02:01 AM           Profile   Send private message  E-mail  Edit post Reply with quote


Hey all,
The login issue seems to be fixed; clicking "Log me in every time" should no longer still log you out.
Important: delete your cookies before relogging in, you might have some bad cookies messing things up.

If there's any issues please let me know.




Top
                 

Cool #9
Cool #9
Joined: 01 Dec 2000
Posts: 41400
PostPosted: 05-30-2017 04:42 AM           Profile   Send private message  E-mail  Edit post Reply with quote


I removed cookies but it still doesn't persist my login :(




Top
                 

Messatsu Ko Jy-ouu
Messatsu Ko Jy-ouu
Joined: 24 Nov 2000
Posts: 43162
PostPosted: 05-30-2017 04:46 AM           Profile   Send private message  E-mail  Edit post Reply with quote


Pls tell me the steps you're taking - tested it on multiple devices and different browsers and I am unable to reproduce the issue.




Top
                 

Etile
Etile
Joined: 19 Nov 2003
Posts: 33002
PostPosted: 05-30-2017 06:31 AM           Profile Send private message  E-mail  Edit post Reply with quote


i heard the fix doesn't work if you have a mangina




Top
                 

Cool #9
Cool #9
Joined: 01 Dec 2000
Posts: 41400
PostPosted: 05-30-2017 06:44 AM           Profile   Send private message  E-mail  Edit post Reply with quote


It's weird. It works with IE, Edge and Chrome but Firefox won't budge.
I deleted my entire browsing history but it won't keep my session active. Oddly enough I also still have the sid in the URL after logging in.




Top
                 

One Man Army
One Man Army
Joined: 23 Dec 1999
Posts: 10512
PostPosted: 05-30-2017 06:57 AM           Profile Send private message  E-mail  Edit post Reply with quote


Works with Firefox here i didn't even toss my cookies




Top
                 

Messatsu Ko Jy-ouu
Messatsu Ko Jy-ouu
Joined: 24 Nov 2000
Posts: 43162
PostPosted: 05-30-2017 07:11 AM           Profile   Send private message  E-mail  Edit post Reply with quote


sure ur not just blocking cookies from this domain in ff?




Top
                 

Arrr?
Arrr?
Joined: 09 Feb 2001
Posts: 33848
PostPosted: 05-30-2017 02:59 PM           Profile   Send private message  E-mail  Edit post Reply with quote


Eraser wrote:
I removed cookies but it still doesn't persist my login :(

Same here. Using Chrome. I disabled adblocker type extensions and it still doesn't persist my login. It did fix the instant-logout bug that I noticed when I first visited the site today, but I saw the sticky thread and deleted my cookies so I can at least log in.

edit: Same problem with FF.



_________________
YourGrandpa wrote:
I'm satisfied with voicing my opinion and moving on.


Top
                 

Etile
Etile
Joined: 19 Nov 2003
Posts: 33002
PostPosted: 05-31-2017 12:05 AM           Profile Send private message  E-mail  Edit post Reply with quote


same here. FF. deleted Q3W cookies. restarted FF. nothing

maybe the internet doesn't like unsecure logins any more :paranoid:




Top
                 

Messatsu Ko Jy-ouu
Messatsu Ko Jy-ouu
Joined: 24 Nov 2000
Posts: 43162
PostPosted: 05-31-2017 01:56 AM           Profile   Send private message  E-mail  Edit post Reply with quote


we're already on ssl




Top
                 

Cool #9
Cool #9
Joined: 01 Dec 2000
Posts: 41400
PostPosted: 05-31-2017 04:33 AM           Profile   Send private message  E-mail  Edit post Reply with quote


seremtan wrote:
same here. FF. deleted Q3W cookies. restarted FF. nothing

maybe the internet doesn't like unsecure logins any more :paranoid:


Lots of mangina's around here :(




Top
                 

Cool #9
Cool #9
Joined: 01 Dec 2000
Posts: 41400
PostPosted: 05-31-2017 04:36 AM           Profile   Send private message  E-mail  Edit post Reply with quote


I might have an idea what the problem is. I browse to quake3world.com, so no https. If I log in no cookies are stored and I stay on a non-secure connection.
If I explicitly browse to https://quake3world.com I get a message that the certificate is invalid (it's self-signed). If I add a security exception for the certificate I can continue browsing through https and a cookie is stored. Also, after accepting the certificate exception, I am redirected to https when I browse to Q3W using http. I know Firefox is a bit more fussy when it comes to certificate security than IE and Chrome.

So the solution for Firefox users is:
- Browse to https://quake3world.com/forum
- You'll get a message about an insecure connection. Click the "add exception" button near the bottom.
- Click "Confirm security exception" in the dialog that opens.
- If that button is not enabled you might have to click "Get certificate" first.
- Firefox will continue showing an insecure connection icon in the URL bar which basically means someone might end up doing a man-in-the-middle attack to get your login credentials and pretend to be you but I'm pretty sure that will only be an improvement in most cases.




Top
                 

Messatsu Ko Jy-ouu
Messatsu Ko Jy-ouu
Joined: 24 Nov 2000
Posts: 43162
PostPosted: 05-31-2017 05:36 AM           Profile   Send private message  E-mail  Edit post Reply with quote


:olo:
Strange, I never added an exception for FF and it works fine for me.
http should also automatically redirect to https serverside.

My FF also doesn't nag about incorrect signed certificates. DooMer set up the ssl cert so he should be able to look into it.
Good to know there's a workaround tho.




Top
                 

Aneurysm
Aneurysm
Joined: 10 Dec 1999
Posts: 11655
PostPosted: 05-31-2017 05:50 AM           Profile   Send private message  E-mail  Edit post Reply with quote


FF works fine for me and I never added an exception.




Top
                 

Messatsu Ko Jy-ouu
Messatsu Ko Jy-ouu
Joined: 24 Nov 2000
Posts: 43162
PostPosted: 05-31-2017 05:51 AM           Profile   Send private message  E-mail  Edit post Reply with quote


Going to http://quake3world.com doesnt seem to work, gives security errors and such.
Browsing to /forum seems to redirect to https, no longer nagging about incorrect certs. Click on the lock icon to see more about the cert - you'll see it's actually provided by Lets Encrypt and that it's not self-signed. Adding an exception should not be needed this way.

I'll check if I can do something about the redirect - although DooMer set it up this way so he might know more about the details why.
Problem is that I can't really repro it the way you guys are experiencing it (mac FF vs win FF perhaps?) so I'm partly stabbing in the dark




Top
                 

Messatsu Ko Jy-ouu
Messatsu Ko Jy-ouu
Joined: 24 Nov 2000
Posts: 43162
PostPosted: 05-31-2017 05:59 AM           Profile   Send private message  E-mail  Edit post Reply with quote


pls try using http://quake3world.com/forum and tell me where you end up.




Top
                 

Etile
Etile
Joined: 19 Nov 2003
Posts: 33002
PostPosted: 05-31-2017 06:59 AM           Profile Send private message  E-mail  Edit post Reply with quote


at same but https




Top
                 

Etile
Etile
Joined: 19 Nov 2003
Posts: 33002
PostPosted: 05-31-2017 07:02 AM           Profile Send private message  E-mail  Edit post Reply with quote


Eraser wrote:
seremtan wrote:
same here. FF. deleted Q3W cookies. restarted FF. nothing

maybe the internet doesn't like unsecure logins any more :paranoid:


Lots of mangina's around here :(


Image




Top
                 

Finno-Persian Legend
Finno-Persian Legend
Joined: 04 Jan 2006
Posts: 15340
PostPosted: 05-31-2017 09:21 AM           Profile   Send private message  E-mail  Edit post Reply with quote


Working now, thanks MKJ and Doomer.

And about fucking time too >:E




Top
                 

Elite
Elite
Joined: 25 Mar 2000
Posts: 9809
PostPosted: 06-01-2017 07:44 PM           Profile Send private message  E-mail  Edit post Reply with quote


Phew... I thought I was going fucking mental. :paranoid:

http://quake3world.com/forum worked for me... didn't need to toss any cookies.




Top
                 

Mew Legs!
Mew Legs!
Joined: 23 Jul 2006
Posts: 906
PostPosted: 06-01-2017 09:13 PM           Profile Send private message  E-mail  Edit post Reply with quote


Works without deleting any cookies here in FF. Nice work.




Top
                 
Quake3World.com | Forum Index | Announcements


Post new topic Reply to topic


cron
Quake3World.com
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group